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Installing a Device Driver for Test Phones

« Extract S8500-Driver-vV5 02 0 0O.zipin
BADA SDK HOME/Tools and run Setup.exe.

« Connect your test phone to your PC with a USB cable.
» Select a folder for the driver location in the Hardware Update Wizard.
The Hardware Update Wizard is shown twice for 2 modem ports.
— Select Install from a list or specific location (Advanced).
— Check Include this location in the search.
— Browse the folder with the device driver.
* Check if there are the 2 modem ports in Device Managetr.
— “Samsung Mobile Modem in V2" in Modem.
— “Samsung Mobile Modem Diagnostic Serial Port V2 (WDM)” in Port.



Downloading Platform Binaries (1/2)

 Run PlatformDownloader.exe in BADA_SDK_HOME/Tools.

Dialog

Cannot find a license file. Search for it or generate a new one.

« Generate license information by clicking Generate License Info.
Dialog E3

. Generate License Info |I

Search License file

Cancel

« Send your license information to your contact point at Samsung.
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Downloading Platform Binaries (2/2)

 When you receive your license file, click Search License file and

select your license file.
Dialag El

{ Generate License Info |

‘ Search License file

Cancel |

« Download the target binaries:

1. Atthe same time, click the SEND and POWER key on the target device.
“Download Mode” appears on the display. ——

2. Connect your target to your PC.
3. Onthe PC, click Port Search and Download.

Generic h2

Mid) ~]
Fis

Generic -
csc
[Generic 3|
SSS

argetSHPbin: ary¥Lismo -
PFS

K|
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Converting Application Projects

For existing projects that do not have a build configuration for a target
environment:
1. Create a new bada Empty project of the correct application type using
the Application Wizard.
« Select the manifest file in the current project folder.

« Verify that Target-Debug is checked under Select Configurations in the
Application Wizard.

2. Copy the original source code files, include files, and resource files to
the new project folder.

3. Change the source code in ProjectNameEntry.cpp:
« Old:

_declspec(dllexport) int OspMain (int argc, char *pArgvl[]);
* New:
_EXPORT int OspMain(int argc, char* pArgv([]);

4. Update the settings for libraries, library paths, and include paths.



Setting Applications (1/2)

You can add library search paths and libraries:

1. Right-click the project and select Properties > C/C++ Build >
Settings > bada C++ Linker > Miscellaneous.

2. Select a configuration and add libraries.

* For example, add ${TARGET_LIB_PATH}/YOUR_LIBRARY.a
ol

hfpe Filter text Settings (S T

-~ Resource
- bada Build
- Builders Configuration: ITarget-Debug j Manage Configurations. ..
= CfC++ Build

- Build Vatiables

- Discavery Options b . ; " » =
* Ervvironment i$) Tool Settings | Build Steps Build Artifact I &4 Binary Parsers I €3 Error Farsers |
i Settings
H = i
‘. ol Chain Editar 215 h;dz C+ Compiler Linker flags |
B C/C++ General I Preprocessor . = m
! g Directaties Other options {-Xlinker [option]) & |D % 'ﬁ | ,G|

- Project References
Refactoring History

@ Optimization

- RunfDebug Settings @ Debugging
[#- Task Repository @ Warnings

@ Miscellaneous
=3 bada C Compiler
@ Preprocessar
@ Symbols
3 pi : =
%: D|re.ctF|rIE.5 Other abjects & o 8 5L
"I Gptimization “EITARGET LI PATHL I
_—1 S TARG] i PATHY osprt0.a"
L Debugging "&{TARGET_LIB_PATHHnewlib,so"
[ Warnings "S{TARGET_LIE_PATHHStubDynCast, so*
-2 Miscellaneous "${TARGET_LIE_PATHHFOsp. 50"
= E83 bada C++ Linker

5 General Add libraries

Lib
= @ bada Assembler
F( General

Restore Defaults | Apply |
3
@ |
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Setting Applications (2/2)

You must change legacy projects in the libraries:

1. You can change Libraries at Properties > C/C++ Build > Settings >
bada C++ Linker > Libraries.

Libraries (-3 | ] o apl 4

stdc++
qcc_s

2. You can change Other objects at Properties > C/C++ Build >
Settings > bada C++ Linker > Miscellaneous.

Other objects ] w) | gl ot

“H T."-"'.Ei GET_LI Ei _E' .":".T|:| osp_rl a”

; _OE- ibc-newlib,
S TARGET-_LIB_PATHE/librn-newlib

A TARGET_LIE_PATHR/StubDynCast so0”
" TARGET_LIB_PATH}/FOsp,s0”

50
.50




Building Applications

* You can change build configurations using the Build Configurations
menu item.

Euclude from build,,,

Build Configurations Set Active 1 Sirmulator-Debug
kake Targets *  Build 8 v ? Target-Debug
Imdes r Delete resource cfgs,,, 3 Target-Release

Show in Bemote Systerns wiew Manage...

* You can build your project using the Build Project menu item.

| Project  Window Help

Open Project
Close Project

ag Build All Cirl+B
Build Configurations 3
Build Project
Build Warking Set 3
Clean,,,

Build Autornatically

FMake Package
Make Target J

Properties
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Install Test Root Certificate to Target

You have to install the test root certificate to target for target testing as

follows.

1. Tab “Settings” as (a)
2. Tab “Connectivity” as (b)
3. Tab “USB” as (c)

Ll 38 = 4 1921 @M
Edit

o 14:05
Settings

w Flight mode
E’E Connectivity

Q@ ¢ o

Social Hub Music

m Sound profiles

E Display and light

General
n‘ Date and time

(b)
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o 14:05 {0
Connectivity

Data roaming

Use packet data

Packet data counter

USB
Samsung Kies

TV out
PAL

(©)

10



Install Test Root Certificate to Target

4. Tab “Mass storage” as (d)
5. Tab “Set” as (e)

usB

Samsung Kies
Media player

Mass storage

PCInternet

Ask on connection

USB debugging

Set Cancel

(d)

6. Connect your target to your PC.

usB

Samsung Kies

Media player

Mass storage

PC Internet

Ask on connection

USB debugging

Set Cancel




Install Test Root Certificate to Target

6. Copy BADA SDK_HOME\Tools\sbuild\rootCACert.cer file to Removable
Disk\Others.

7. Tab “My files” as (f)
8. Tab “Others” as (g)

B% sounds

'a Themes

r% Others

Create
folder sse Search

(9)




Install Test Root Certificate to Target

9. Tab “rootCACert.cer” as (h)
10. Tab “Install” as (i)
11. You can see the “Installed” message as (j)

' rootCACert.cer

Open Source Ann...  &.

Install trusted root

certificate?
Installed
p i




Preparing to Run/Debug Applications

You should change your target to the debug mode by the following

step.

}

Social Hub

o

i
-

Internet

E

Calendar Samsung Apps  Smart search

®C

Camera Settings

's
=
14

Keypad Contacts Messages

Settings

w Flight mode

.,. Connectivity

m Sound profiles

E Display and light

1401

o 14:01 (1
Connectivity

Data roaming

Use packet data

Packet data counter

USB
Mass storage

TV out
PAL

Samsung Kies

Media player

Mass storage

PC Internet

Ask on connection

USB debugging

Set




Running Applications (1/2)

You can run an application using the Run As menu item.

— The executable binary, resource files, and data files are downloaded
before starting the run.

— The application is installed automatically while it runs.

Show in Bernote Systemns view
Convert To,,,

Bun &s J
Debug As k
Profile &s k
Team b
Compare With J
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Running Applications (2/2)

If the source code has been changed, you can download only the
executable binary to your target without updating the other files:

— The option is only available for the Target-Debug and Target-Release build

configurations.

1. Select Run Configurations....

Debug &s
Profile As
Team
Compare With

b
b

ada Simulator &pplication
ada Target &pplication
¢ | 3 Local CAC++ Application

Create, manage, and run configurations

e B

fupe filter text

(] 5= bada Target Applicatior
¢ i-fal UiControls Target-D
@ C/C++ Application
[E] CAC++ Remate Applicat
ifp Launch Group

[l —

Filter matched B of 6 iterns

MNamne: |UiC0nlr0Is Target-Debug

[5] Main ™ (s Cnnnectinnﬁ 9= Argumentﬂ w Envirnnmenq = Qnmmmnﬁ

Project:

[UiCantrols
Code binary path:

[. Target-DebugiControls, exe

Code binary path in target file systern:

Browse,,,

Search Project,.. | Browese, .. |

[/Osp/Applications

I~ Qverwilte cons, resalirces, and data files on the target!

Q)
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Exiting Applications

« Terminating with bada IDE

— Click the Terminate button in the Console or Debug window to
terminate the run operation of the bada IDE.

& | Sliv &~

xe (10, 3, 20, 2= 6510

El console £3 | “E‘E@|=;&E,l=:v
HelloWaorld Target-Debug [bada Target Application] c: fhada¥S0K M 0,061 W T ools WEroker WEroker, e TS, 20, £ = 6:51)
=

z2,0,0,1,2010-03-20,158:52:04.387,3993 1355.204 P30.T106.D001.G0O0.E-01:0000 EXCEFTION > _ Rsrclnit3t

2,0,0,1,2010-03-20,18:52:04.387,3994 13858.205 P30.T106.D001.GO0.E-01:0000 EXCEFTION » _ Rsrclnitdt

2,0,0,1,2010-03-20,18:52:04.387,3995 1388.205 P30.T106.D001.GO0.E-01:0000 EXCEPTICN >  Rsrclnit3t

z,0,0,1,2010-03-20,15:52:04.357,3996 1355.205 P30.T106.D001.G0O0.E-01:0000 EXCEFTION » _ RsrcInit3tc

-
«| | »

— An application is exited only after clicking the Terminate button followed
by some other action in the application. For example, after clicking the
Terminate button and some other button in the application.

« Terminating in your target device

— Press the End key on your target device to terminate your application
easily.
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Debugging Applications

For general information on debugging content, see Debugging

Applications in the Development Environment tutorial.

To debug the application on your target, right-click the project in

Project Explorer and select Debug as > bada Target Application.

* The limitations for debugging in the target are:
— Only four breakpoints can be inserted due to hardware limitation.

— An application is suspended only after clicking the Suspend button
followed by some other action in the application. For example, after
clicking the Suspend button and some other button in the application.

ﬁ‘; Debug 53

&1

LILf

O =i E|@y=0




Stop Debugging

« Stopping with bada IDE

— Click the Terminate button in the Console or Debug window to
terminate the run operation of the bada IDE.

%5 Debug 23 &t | %|i=€>_‘T5?|t{><9v

— An application is exited only after clicking the Terminate button followed
by some other action in the application. For example, after clicking the
Terminate button and some other button in the application.

— Reconnect the USB cable.



Error Codes (1/3)

* You can check the detailed description about error codes in the
following table.

0101 Installation aborted: Another installation is in progress.
Multiple applications cannot be installed at the same time.

0102 Installation error: Invalid package.
Application cannot be installed properly because some of the package contents are invalid or missing.

Inctallatinn failad

ErrorCode : 0115 0103 Installation error: Maximum number of applications reached.
The count of applications that can be installed has reached the maximum limit. Uninstall some

“ application first and try again.

0104 Installation error: Insufficient storage. Free some memory and try again.
There is not enough storage available to install this application. Free some memory by removing
unnwanted media files, or uninstalling some existing applications.

0105 Installation error: Certificate Parsing Error.
A certificate parsing error occurred. This error indicates that the certificate is invalid in Signature.xml.
For the application integrity check, the chain of the certificate should be verified before actual installation.

0106 Installation error: Certificate has expired.
The certificate used to sign the application has expired.

0107 Installation error: Certificate is revoked."), wxT("The certificate used to sign the application has been
revoked according to the result of OCSP protocol.

0108 Installation error: Failed to find root certificate."), wxT("The root certificate, which is required to make
certificate chain for the application integrity check, is not found in the device.

0109 Installation error: Signature verification failed."), wxT ("Failed to verify application signature.

0110 Installation error: Application metadata registration failed."), wxT ("Application metadata required to verify

application integrity is missing or invalid.
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Error Codes (2/3)

0111 Installation error: Application signature missing or invalid.
Application signature required for verifying application integrity is missing or invalid.

0112 Installation error: Application manifest missing or invalid.
The application manifest specifying metadata of the application is missing or invalid.

0113 Installation error: Invalid application executable file.
Executable binary of the application was not found or invalid.

0114 Installation error: Invalid application information.
Application information file specifying application name, icon path, etc., was not found or invalid.

0115 Installation error: Privilege registration failed.
Failed to register privilege information to system database during installation.

0116 Installation error: Unknown Error
Installation failed due to unknown reason.

0117 Installation error: Main menu icon missing.
The application's Main menu icon is missing.

0118 Installation error: Setting menu icon missing.
The application's Setting menu icon is missing.

0119 Installation error: Ticker icon missing.
The application's Ticker icon is missing.

0120 Installation error: Quick panel icon missing.
The application's Quick panel icon is invalid.

0121 Installation error: Launch image missing.
The application's Launch image is invalid.

0122 Installation error: Main menu icon name invalid.
The file name of the Main menu icon cannot be properly extracted from the application package.
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Error Codes (3/3)

0123

0124

0125

0126

0127

0128

0201

0202

0203

Installation error: Setting menu icon name invalid.
The file name of the Setting menu icon cannot be properly extracted from the application package.

Installation error: Ticker icon name invalid.
The file name of the Ticker icon cannot be properly extracted from the application package.

Installation error: Quick panel icon name invalid.
The file name of the Quick panel icon cannot be properly extracted from the application package.

Installation error: Launch image name invalid.
The file name of the launch image cannot be properly extracted from the application package.

Installation error: License acquisition failed.
Failed to acquire the license during DRM file installation.

Installation error: Failed to decrypt DRM package.
Failed to decrypt the DRM package with the license file due to some reason like key not found.

Launch error: No License.
The application does not have the rights to be launched or PNUM does not match.

Launch error: Signature verification failed.
Verification of signature has failed because the application binary or hash table file has been modified after installation.

Launch error: File(s) missing for signature verification.
Files required for hash checking are missing.
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Checking Debug Messages

« Start the Output pane by selecting Window > Show View >
Other... > bada — Output.

 The usage for the Output pane is the same as for the simulator
environment.

El Console | & Tasks || File Explorer | {2 Problems |3 Executables | Bl Quiput 53 B E il E %y~ —0O

1145 075,486 1,130, 29, 58:0245 EXCEPTION > PrmCreateProcess() @ takes (Ims ~
IZIEI'."E EEEI Ell -0 OspMaln (23} > .fl".pphl:atmn started
AT o A [HIR 0 here 1sn t correct Applnfo

1147 078, 323 2EI oo, 38 '."B anan EXCEF‘TIDN > Add Create root window by £2). (EventDispatcher31) synchranously by hinst

1148 078,325 1.001,07 28:0277 EXCEPTION » __Watchdog : Restored the focused window to main window(12) by perforce,

1149 078,378 79,001,38, 78:0000 EXCEPTION > __WsMainCanstructar: The main style isn't MAIN_STYLE_DISPLAY _DIRECTION,. S0 rotate the vertical direr
1150 073,329 29,001,385, 75:0000 EXCERPTION » CWsRotate: StopGSensor @ G Sensor On /Off =0

151 078,353 1,001, 07, 28:0274 EXCEPTION > WmSurfMarBemoveSurface: hSurface doesn't exist in the screen or has already been remowved

B2 078,354 1.001,07, 28:0274 EXCEPTION » _WrmRemoveOverlay @ WmSurftarRemoveSurface(0.1) has failed.

53 078,355 1,000,077, 28:0274 EXCEPTION » [CWsRotate::ValidateDisplayDirection] TopMosttaini12, EventDispatcher3!) is not current task, so send C
54 078,357 1,000, 07, 28:0274 EXCEPTION » PshDispatchRequest: Unkonwn dispatch type {314}!

EE 078,361 29,001,38,78:0000 EXCEPTION > WrmSurftgrGetTopMostSurface: The screen list is empty!

G 073,643 29,001,358, 78:0278 EXCEF’TION > CWSHDtate StanSensnr G Sensnr already stnped w

=2 onn™ Foc 14 nni I'il'i O 0mnd PSS TR AT

1
1l
1l
1l
1l
N

£

* You can also show debug messages in the Console pane.



Getting Debug Information

You can get debug information after the target terminates abnormally

during debugging:

— Debug information includes stack frame.
— Select Project > Get Debug Information.

'I.- y
L™ Project Explorer &3

v

= = Helloworld
--ﬁ,‘f Binaries
-l Includes
- sre
HmE}hc

-2 Res
o Q application.xml

------ [l maniFest.xml

5] stackframe.bxt 2
FC:

Ox9554x1300

Ox955412E5 GLOBAL I HelloWorld.cpp
Ox256E095D AppFriowkDispatchdIP
0x9660EFSF  Ezl1WsClearGlobalVariahbhlew

Ox95D16C32 LE: Ox95D16C33 Stack PTR @
O0x95D16C32  EN3OspdBasetitringeippendEPEw
O0x95016C33 EN3ospdBasecitringdippendEPEw
0x295D16D55 IN3ospdBasecitringsippendERES1

Ox0927ECLD
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